summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-04 23:33:59 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-04 23:35:55 +0200
commite9f693d06f94bd96488c3910dba6504f94a6b6f9 (patch)
tree907d045b9d59ddfe832c80505949d7eff5267013 /Makefile.am
parent957afcae3cded622f4260385f69b40dbdcaade9f (diff)
downloadpatches-e9f693d06f94bd96488c3910dba6504f94a6b6f9.tar
patches-e9f693d06f94bd96488c3910dba6504f94a6b6f9.tar.gz
tests: Add whole-system test.
* gnu/system/vm.scm (virtualized-operating-system): Export. * gnu/tests/base.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * Makefile.am (check-system): New target.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e8dfd318f..e0be844bfd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -330,6 +330,13 @@ check-local:
endif !CAN_RUN_TESTS
+check-system: $(GOBJECTS)
+ $(AM_V_at)echo "Running system tests..."
+ $(AM_V_at)$(top_builddir)/pre-inst-env \
+ $(GUILE) --no-auto-compile \
+ -e '(@@ (run-system-tests) run-system-tests)' \
+ $(top_srcdir)/build-aux/run-system-tests.scm
+
# Public key used to sign substitutes from hydra.gnu.org.
dist_pkgdata_DATA = hydra.gnu.org.pub