summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-04-13 19:18:03 +0200
committerLudovic Courtès <ludo@gnu.org>2016-04-13 19:20:03 +0200
commit89cbec89a57c2e10042a19c298c8c000e6bce13b (patch)
tree8da0f965b8eea204bd842fca4e662d403e4f9c00 /Makefile.am
parent9c3bb4c54d67899394af81c819fe60f391e35edf (diff)
downloadpatches-89cbec89a57c2e10042a19c298c8c000e6bce13b.tar
patches-89cbec89a57c2e10042a19c298c8c000e6bce13b.tar.gz
hydra: Add 'hydra-jobs.scm' target to compute the Hydra jobs.
* build-aux/hydra/evaluate.scm: New file. * Makefile.am (EXTRA_DIST): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c00db1ab3..1f257a009c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -339,6 +339,7 @@ EXTRA_DIST = \
.dir-locals.el \
build-aux/build-self.scm \
build-aux/compile-all.scm \
+ build-aux/hydra/evaluate.scm \
build-aux/hydra/gnu-system.scm \
build-aux/hydra/demo-os.scm \
build-aux/hydra/guix.scm \
@@ -489,6 +490,14 @@ assert-final-inputs-self-contained:
$(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-final-inputs-self-contained.scm"
+# Compute the Hydra jobs and write them in the target file.
+hydra-jobs.scm: $(GOBJECTS)
+ $(AM_V_at)$(MKDIR_P) "`dirname "$@"`"
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env "$(GUILE)" \
+ "$(top_srcdir)/build-aux/hydra/evaluate.scm" \
+ "$(top_srcdir)/build-aux/hydra/gnu-system.scm" > "$@.tmp"
+ $(AT_V_at)mv "$@.tmp" "$@"
+
.PHONY: sync-descriptions gen-ChangeLog gen-AUTHORS clean-go make-go
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained