summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-22 23:23:38 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-23 00:33:50 +0200
commita7a4e6a4f719da8d0b26d9a60ff8ed42691d263f (patch)
tree8e403c97847edcadcc4da900d7e1c48e675df4bf /Makefile.am
parent996ed6acd5586f9db08a9388442acdd044285fe4 (diff)
downloadpatches-a7a4e6a4f719da8d0b26d9a60ff8ed42691d263f.tar
patches-a7a4e6a4f719da8d0b26d9a60ff8ed42691d263f.tar.gz
Add 'guix-register'.
* nix/guix-register/guix-register.cc, tests/guix-register.sh: New files. * Makefile.am (SH_TESTS)[BUILD_DAEMON]: Add tests/guix-register.sh. * daemon.am (sbin_PROGRAMS, guix_register_SOURCES, guix_register_CPPFLAGS, guix_register_LDADD): New variables. * test-env.in: Export 'storedir', 'prefix', 'datarootdir', 'datadir', and 'localstatedir'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bf9c1d0e91..7dc79e26e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,6 +117,13 @@ SH_TESTS = \
tests/guix-hash.sh \
tests/guix-package.sh
+if BUILD_DAEMON
+
+SH_TESTS += tests/guix-register.sh
+
+endif BUILD_DAEMON
+
+
TESTS = $(SCM_TESTS) $(SH_TESTS)
TEST_EXTENSIONS = .scm .sh