summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-27 09:56:45 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-27 15:08:17 +0200
commitdbab5eb8f52963ffff5742ebbdf6ce7919e18ab1 (patch)
treebf6a9018781dcf38e1385377fc4067fcb9e4b4b5 /Makefile.am
parent6cd7b1be7ea2b675e369c6cbb35b31b3c496648b (diff)
downloadpatches-dbab5eb8f52963ffff5742ebbdf6ce7919e18ab1.tar
patches-dbab5eb8f52963ffff5742ebbdf6ce7919e18ab1.tar.gz
maint: Pass '--image-size=30G' to 'guix system vm-image'.
* Makefile.am (GUIX_SYSTEM_VM_IMAGE_FLAGS): New variable. (release): Use it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 99d6ed64b6..f25900de0f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -684,6 +684,10 @@ GUIX_SYSTEM_IMAGE_BASE = guix-system-install-$(PACKAGE_VERSION)
# Prefix of the Guix VM image file name.
GUIX_SYSTEM_VM_IMAGE_BASE = guix-system-vm-image-$(PACKAGE_VERSION)
+# Flags for 'guix system vm-image'. By default create a VM image that appears
+# to have a 20G hard disk.
+GUIX_SYSTEM_VM_IMAGE_FLAGS ?= --image-size=30G
+
# Return the sequence of '-s' flags for the given systems.
system_flags = $(foreach system,$(1),-s $(system))
@@ -750,7 +754,7 @@ release: dist
done
for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do \
image=`$(top_builddir)/pre-inst-env \
- guix system vm-image \
+ guix system vm-image $(GUIX_SYSTEM_VM_IMAGE_FLAGS) \
--system=$$system \
gnu/system/examples/vm-image.tmpl` ; \
if [ ! -f "$$image" ] ; then \