summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-12-30 23:22:27 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-31 01:44:04 +0100
commit987a29ba43cc8a2751eafe392906d240713c724e (patch)
tree70ea45295acc64daf0d87a22df51ec617e9a5bf4 /Makefile.am
parent68415aa4e16f1951fa319cca00c322fa96fee494 (diff)
downloadpatches-987a29ba43cc8a2751eafe392906d240713c724e.tar
patches-987a29ba43cc8a2751eafe392906d240713c724e.tar.gz
Add (guix ssh) module.
* guix/scripts/offload.scm (connect-to-remote-daemon) (store-import-channel, store-export-channel, send-files) (retrieve-files): Move to (guix ssh). (nonce): Add optional 'name' parameter and use it. (retrieve-files*): New procedure. (transfer-and-offload): Use it instead of 'retrieve-files', and add first parameter to 'send-files'. (assert-node-can-import): Likewise. (assert-node-can-export): Use 'retrieve-files' instead of 'store-export-channel'. * guix/ssh.scm: New file. * configure.ac: Use 'GUIX_CHECK_GUILE_SSH' and define 'HAVE_GUILE_SSH' Automake conditional. * Makefile.am (MODULES) [HAVE_GUILE_SSH]: Add guix/ssh.scm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 97629f26e6..094d6e5108 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -170,6 +170,13 @@ MODULES += \
endif
+if HAVE_GUILE_SSH
+
+MODULES += \
+ guix/ssh.scm
+
+endif HAVE_GUILE_SSH
+
if BUILD_DAEMON_OFFLOAD
MODULES += \