summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-06-14 21:53:25 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-14 22:09:38 +0200
commit92d00ca4661e186022732a47956a2bc0ef16be96 (patch)
tree048f65570b56a062cfe1e183d75c595c80cb7816 /Makefile.am
parent1ba0b1e6ec41afd94a3c5f907b1122204dcb5d9d (diff)
downloadpatches-92d00ca4661e186022732a47956a2bc0ef16be96.tar
patches-92d00ca4661e186022732a47956a2bc0ef16be96.tar.gz
build: Remove 'gnu/packages/bootstrap' and its binaries.
* gnu/local.mk (bootstrapdir, bootstrap_i686_linuxdir) (bootstrap_armhf_linuxdir, bootstrap_aarch64_linuxdir) (bootstrap_mips64el_linuxdir, dist_bootstrap_i686_linux_DATA) (dist_bootstrap_armhf_linux_DATA, dist_bootstrap_aarch64_linux_DATA) (dist_bootstrap_mips64el_linux_DATA): Remove. (set-bootstrap-executable-permissions): Remove target. * Makefile.am (install-data-hook): Remove dependency on 'set-bootstrap-executable-permissions'. * gnu/packages/bootstrap: Remove directory. * tests/search-paths.scm ("evaluate-search-paths, separator is #f"): Adjust to match .../aux-files/linux-libre.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 80be73e4bf..ec1e0285ea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -589,7 +589,7 @@ $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
# The above trick doesn't work for 'config.go' because both 'config.scm' and
# 'config.go' are listed in $(nobase_nodist_guileobject_DATA). Thus, give it
# special treatment.
-install-data-hook: set-bootstrap-executable-permissions
+install-data-hook:
touch "$(DESTDIR)$(guileobjectdir)/guix/config.go"
# Assuming Guix is already installed and the daemon is up and running, this