summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2019-01-29 23:07:33 -0600
committerEric Bavier <bavier@member.fsf.org>2019-02-07 21:21:13 -0600
commit92becc3f15ce196a94274f80ee0b6594774856fa (patch)
treec77cbf5d6b05cc31a0d55493dc1bff506c5aed87 /Makefile.am
parent7b84610e2113d634c962020e4715a34518060918 (diff)
downloadpatches-92becc3f15ce196a94274f80ee0b6594774856fa.tar
patches-92becc3f15ce196a94274f80ee0b6594774856fa.tar.gz
build: clean-go: Do not warn about *.go files in "test-tmp".
* Makefile.am (clean-go): Ignore "test-tmp" directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0590c51519..fec9800ce7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -318,7 +318,7 @@ nobase_nodist_guileobject_DATA = $(GOBJECTS)
# Handy way to remove the .go files without removing all the rest.
clean-go:
-$(RM) -f $(GOBJECTS)
- @find . -name '*.go' -print | \
+ @find . -path ./test-tmp -prune -o -name '*.go' -print | \
if test -t 1; then \
xargs -r echo -e "\033[31mwarning:\033[0m stray .go files:"; \
else \