summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2016-06-17 22:44:37 +0300
committerManolis Ragkousis <manolis837@gmail.com>2016-06-23 17:25:37 +0300
commit875715cabfeb7816cea16269cfbdbad08442a73e (patch)
tree6cb213243e70062b4215006fb2e17663fae178b0 /Makefile.am
parenta12f6f498a7d1087fdf901e9e9604baf702c6c1e (diff)
downloadpatches-875715cabfeb7816cea16269cfbdbad08442a73e.tar
patches-875715cabfeb7816cea16269cfbdbad08442a73e.tar.gz
build: Remove unneeded conditionals for (guix build syscalls).
* m4/guix.m4: Remove 'GUIX_CHECK_LIBC_MOUNT'. * configure.ac: Remove 'BUILD_SYSCALLS_MODULE'. * Makefile.am (MODULES): Add 'guix/build/syscalls.scm'. (EXTRA_DIST): Remove conditional on BUILD_SYSCALLS_MODULE.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 1 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 8fd1c1b0b6..fd76be4d72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,6 +101,7 @@ MODULES = \
guix/build/rpath.scm \
guix/build/cvs.scm \
guix/build/svn.scm \
+ guix/build/syscalls.scm \
guix/build/gremlin.scm \
guix/build/emacs-utils.scm \
guix/build/graft.scm \
@@ -157,13 +158,6 @@ MODULES += \
endif
-if BUILD_SYSCALLS_MODULE
-
-MODULES += \
- guix/build/syscalls.scm
-
-endif
-
if BUILD_DAEMON_OFFLOAD
MODULES += \
@@ -384,13 +378,6 @@ EXTRA_DIST += \
endif !BUILD_DAEMON_OFFLOAD
-if !BUILD_SYSCALLS_MODULE
-
-EXTRA_DIST += \
- guix/build/syscalls.scm
-
-endif !BUILD_SYSCALLS_MODULE
-
CLEANFILES = \
$(GOBJECTS) \