summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-09 11:31:42 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-09 11:52:23 +0200
commit808084e9d1ba7d78621bf4c441c7ddb616849683 (patch)
tree35a96940e837a667c551e22a2c527b19855c8d04 /Makefile.am
parent7bc71025ccd0fabd739803889825e10341fbabdf (diff)
downloadpatches-808084e9d1ba7d78621bf4c441c7ddb616849683.tar
patches-808084e9d1ba7d78621bf4c441c7ddb616849683.tar.gz
maint: Binary tarball uses "guile3.0-guix", not "guix".
* Makefile.am (GUIX_FOR_BINARY_TARBALL): New variable. (guix-binary.%.tar.xz): Use $(GUIX_FOR_BINARY_TARBALL) instead of "guix". (release): Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 344ecdbc42..94348ff00d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -662,11 +662,15 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-daemon \
ac_cv_guix_test_root="$(GUIX_TEST_ROOT)"
+# Name of the 'guix' package shipped in the binary tarball.
+GUIX_FOR_BINARY_TARBALL = guile3.0-guix
+
# The self-contained tarball.
guix-binary.%.tar.xz:
$(AM_V_GEN)GUIX_PACKAGE_PATH= \
tarball=`$(top_builddir)/pre-inst-env guix pack -K -C xz \
- -s "$*" --localstatedir --profile-name=current-guix guix` ; \
+ -s "$*" --localstatedir --profile-name=current-guix \
+ $(GUIX_FOR_BINARY_TARBALL)` ; \
cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
@@ -769,7 +773,7 @@ release: dist
"`git rev-parse HEAD`" "$(PACKAGE_VERSION)"
git add $(top_srcdir)/gnu/packages/package-management.scm
git commit -m "gnu: guix: Update to $(PACKAGE_VERSION)."
- $(top_builddir)/pre-inst-env guix build guix \
+ $(top_builddir)/pre-inst-env guix build $(GUIX_FOR_BINARY_TARBALL) \
$(call system_flags,$(SUPPORTED_SYSTEMS)) \
-v1 --no-grafts -K
rm -f $(BINARY_TARBALLS)