summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-06 22:27:57 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-10 17:09:47 +0200
commit72eda0624be89ed18302fd7d7f22976071ab020c (patch)
tree8ce31092c5a3710dab305116d18d5829b50487a0 /Makefile.am
parent08d0f950b3ad936b859064c070be16548684cbd1 (diff)
downloadpatches-72eda0624be89ed18302fd7d7f22976071ab020c.tar
patches-72eda0624be89ed18302fd7d7f22976071ab020c.tar.gz
Add (guix store roots).
* guix/store/roots.scm, tests/store-roots.scm: New files. * Makefile.am (STORE_MODULES): Add guix/store/roots.scm. (SCM_TESTS): Add tests/store-roots.scm.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 87682b4949..704f2451c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -277,7 +277,8 @@ endif BUILD_DAEMON_OFFLOAD
# Scheme implementation of the build daemon and related functionality.
STORE_MODULES = \
guix/store/database.scm \
- guix/store/deduplication.scm
+ guix/store/deduplication.scm \
+ guix/store/roots.scm
MODULES += $(STORE_MODULES)
@@ -408,7 +409,8 @@ SCM_TESTS = \
tests/pypi.scm \
tests/import-utils.scm \
tests/store-database.scm \
- tests/store-deduplication.scm
+ tests/store-deduplication.scm \
+ tests/store-roots.scm
SH_TESTS = \
tests/guix-build.sh \