summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2014-09-27 10:16:23 -0400
committerDavid Thompson <dthompson2@worcester.edu>2014-09-29 19:30:28 -0400
commit1b3e968512ebbccf02d00c52f7e089156946f445 (patch)
treec45d203439ab9a74d01f2c76850cafb847a755e2 /Makefile.am
parent2efb3ddaa434b86a841dffbba89e21d2d9208526 (diff)
downloadpatches-1b3e968512ebbccf02d00c52f7e089156946f445.tar
patches-1b3e968512ebbccf02d00c52f7e089156946f445.tar.gz
import: Add PyPI importer.
* guix/snix.scm: Delete. * guix/import/snix.scm: New file. * guix/import/pypi.scm: New file. * guix/import/utils.scm: New file. * guix/scripts/import/nix.scm: New file. * guix/scripts/import/pypi.scm: New file. * tests/pypi.scm: New file. * tests/snix.scm: Import (guix import snix) module. * guix/scripts/import.scm (%default-options, %options): Delete. (%standard-import-options, importers): New variables. (show-help): List importers. (guix-import): Factor out Nix-specific logic. Delegate to correct importer based upon first argument. * configure.ac (HAVE_GUILE_JSON): New conditional. * Makefile.am (MODULES): Add new files and remove 'guix/snix.scm'. (SCM_TESTS): Add 'tests/pypi.scm' if guile-json is installed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c22a77f1e..a1a87c09fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,7 +75,9 @@ MODULES = \
guix/build/syscalls.scm \
guix/build/emacs-utils.scm \
guix/packages.scm \
- guix/snix.scm \
+ guix/import/utils.scm \
+ guix/import/snix.scm \
+ guix/import/pypi.scm \
guix/scripts/download.scm \
guix/scripts/build.scm \
guix/scripts/archive.scm \
@@ -89,6 +91,8 @@ MODULES = \
guix/scripts/refresh.scm \
guix/scripts/system.scm \
guix/scripts/lint.scm \
+ guix/scripts/import/nix.scm \
+ guix/scripts/import/pypi.scm \
guix.scm \
$(GNU_SYSTEM_MODULES)
@@ -162,6 +166,12 @@ SCM_TESTS = \
tests/syscalls.scm \
tests/lint.scm
+if HAVE_GUILE_JSON
+
+SCM_TESTS += tests/pypi.scm
+
+endif
+
SH_TESTS = \
tests/guix-build.sh \
tests/guix-download.sh \