summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-05-21 23:25:23 +0200
committerLudovic Courtès <ludo@gnu.org>2020-05-22 00:35:23 +0200
commit1ad5209d904d471ded6cf53b4e29b64e963dea3f (patch)
treeb06d124000073c4f101ac6bced8df077808595ec /Makefile.am
parent5e46b827cf79c064372a99537e469505218def0a (diff)
downloadpatches-1ad5209d904d471ded6cf53b4e29b64e963dea3f.tar
patches-1ad5209d904d471ded6cf53b4e29b64e963dea3f.tar.gz
maint: Add "make check-channel-news".
* build-aux/check-channel-news.scm: New file. * Makefile.am (EXTRA_DIST): Add it. (check-channel-news): New phony rule. * doc/contributing.texi (Commit Access): Mention "make check-channel-news".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fd368d7493..3113e6b042 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -557,6 +557,7 @@ EXTRA_DIST += \
build-aux/cuirass/guix-modular.scm \
build-aux/cuirass/hydra-to-cuirass.scm \
build-aux/check-final-inputs-self-contained.scm \
+ build-aux/check-channel-news.scm \
build-aux/compile-as-derivation.scm \
build-aux/generate-authors.scm \
build-aux/git-authenticate.scm \
@@ -885,6 +886,11 @@ assert-final-inputs-self-contained: $(GOBJECTS)
$(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)" \
"$(top_srcdir)/build-aux/check-final-inputs-self-contained.scm"
+# Validate channel news.
+check-channel-news: $(GOBJECTS)
+ $(AM_V_at)$(top_builddir)/pre-inst-env "$(GUILE)" \
+ "$(top_srcdir)/build-aux/check-channel-news.scm"
+
# Compute the Hydra jobs and write them in the target file.
hydra-jobs.scm: $(GOBJECTS)
$(AM_V_at)$(MKDIR_P) "`dirname "$@"`"
@@ -904,7 +910,7 @@ cuirass-jobs.scm: $(GOBJECTS)
.PHONY: gen-ChangeLog gen-AUTHORS gen-tarball-version
.PHONY: assert-no-store-file-names assert-binaries-available
-.PHONY: assert-final-inputs-self-contained
+.PHONY: assert-final-inputs-self-contained check-channel-news
.PHONY: clean-go make-go as-derivation authenticate
.PHONY: update-guix-package update-NEWS release