summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-09-24 10:11:38 +0200
committerLudovic Courtès <ludo@gnu.org>2019-09-24 10:11:38 +0200
commit11da634a6e64afa2904542e2174aa2a185f9ac3a (patch)
tree5aeb8e6bd01761813650067af492b1c336886e34 /Makefile.am
parente5efdbce21a0afcbb3e73cc7b59111ccf62cb532 (diff)
parent7b3f56f5d7f4d2bb936e1579ed442e7f5b080abd (diff)
downloadpatches-11da634a6e64afa2904542e2174aa2a185f9ac3a.tar
patches-11da634a6e64afa2904542e2174aa2a185f9ac3a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index b5e7a01dce..2b78091af3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -241,6 +241,7 @@ MODULES = \
guix/scripts/remove.scm \
guix/scripts/upgrade.scm \
guix/scripts/search.scm \
+ guix/scripts/show.scm \
guix/scripts/gc.scm \
guix/scripts/hash.scm \
guix/scripts/pack.scm \
@@ -306,7 +307,10 @@ STORE_MODULES = \
MODULES += $(STORE_MODULES)
# Internal modules with test suite support.
-dist_noinst_DATA = guix/tests.scm guix/tests/http.scm
+dist_noinst_DATA = \
+ guix/tests.scm \
+ guix/tests/http.scm \
+ guix/tests/git.scm
# Auxiliary files for packages.
AUX_FILES = \
@@ -390,6 +394,7 @@ SCM_TESTS = \
tests/file-systems.scm \
tests/gem.scm \
tests/gexp.scm \
+ tests/git.scm \
tests/glob.scm \
tests/gnu-maintenance.scm \
tests/grafts.scm \
@@ -528,8 +533,10 @@ EXTRA_DIST += \
TODO \
CODE-OF-CONDUCT \
.dir-locals.el \
+ .guix-channel \
scripts/guix.in \
etc/guix-install.sh \
+ etc/news.scm \
build-aux/build-self.scm \
build-aux/compile-all.scm \
build-aux/hydra/evaluate.scm \
@@ -814,7 +821,8 @@ assert-no-store-file-names:
$(AM_V_at)if grep -r --exclude=*.texi --exclude=*.info \
--exclude=*.info-[0-9] --exclude=*.dot \
--exclude=*.eps --exclude-dir=bootstrap \
- --exclude=guix-manual.pot --exclude=guix-manual.*.po \
+ --exclude=guix-manual.pot --exclude=guix-manual.*.po \
+ --exclude=guix-cookbook.pot --exclude=guix-cookbook.*.po \
--exclude=guix-prettify.el \
--exclude=ChangeLog* \
--exclude=binutils-boot-2.20*.patch \