summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-10 12:26:21 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-10 12:26:21 +0200
commit08b14ab20ebe181690df6210a0b3f95bad494af5 (patch)
tree9a3c53f2662ae01792454b0d2005105a12708903 /Makefile.am
parenteb0352e5b075385baebd907081682f14703ef5e0 (diff)
downloadpatches-08b14ab20ebe181690df6210a0b3f95bad494af5.tar
patches-08b14ab20ebe181690df6210a0b3f95bad494af5.tar.gz
maint: 'release' targets runs ./bootstrap for new version string.
Reported by Vagrant Cascadian <vagrant@debian.org>. * Makefile.am (dist-with-updated-version): New target. (release): Depend on 'dist-with-updated-version'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 654734a991..36f23b4062 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -705,6 +705,16 @@ gen-AUTHORS:
"$(top_srcdir)" "$(distdir)/AUTHORS"; \
fi
+# Like 'dist', but regenerate 'configure' so we get an up-to-date
+# 'PACKAGE_VERSION' string. (In Gnulib, 'GNUmakefile' has a special trick to
+# do that whenever a 'dist' target is used.)
+dist-with-updated-version:
+ @echo "Running './bootstrap' for new version string..."
+ $(top_srcdir)/bootstrap
+ $(MAKE) $(AM_MAKEFLAGS) $(top_srcdir)/.version dist
+
+.PHONY: dist-with-updated-version
+
#
# Release management.
@@ -760,7 +770,7 @@ system_flags = $(foreach system,$(1),-s $(system))
#
# XXX: Depend on 'dist' rather than 'distcheck' to work around the Gettext
# issue described at <https://savannah.gnu.org/bugs/index.php?51027>.
-release: dist
+release: dist-with-updated-version
cd po; git checkout .
@if ! git diff-index --quiet HEAD; then \
echo "There are uncommitted changes; stopping." >&2 ; \