summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-29 14:48:57 +0800
committer宋文武 <iyzsong@gmail.com>2015-08-29 15:07:54 +0800
commitde3d612a525223d3bec2ad182cdfd97cb5d4624d (patch)
tree3ca2493cc8c39ad2d092a82f5254f76c752caa30
parentc3b97bd902cbcf9a59f24997ebfb6fcf4186c6f6 (diff)
downloadpatches-de3d612a525223d3bec2ad182cdfd97cb5d4624d.tar
patches-de3d612a525223d3bec2ad182cdfd97cb5d4624d.tar.gz
gnu: Add yelp.
* gnu/packages/gnome.scm (yelp): New variable.
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index febb11b68b..8d66ed35fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3395,3 +3395,38 @@ of running programs and invoke methods on those interfaces.")
"Yelp-xsl contains XSL stylesheets that are used by the yelp help browser
to format Docbook and Mallard documents.")
(license license:gpl2+)))
+
+(define-public yelp
+ (package
+ (name "yelp")
+ (version "3.16.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1jk7aad1srykhgc3x0hd3q3dnlshmy1ak00alwjzaasxvy6hp0b0"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-genmarshal, etc.
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("dconf" ,dconf)))
+ (inputs
+ `(("libxslt" ,libxslt)
+ ("sqlite" ,sqlite)
+ ("webkitgtk" ,webkitgtk-2.4)
+ ("yelp-xsl" ,yelp-xsl)
+ ;; XXX: need by libwebkitgtk-3.0.la.
+ ("icu4c" ,(@ (gnu packages icu4c) icu4c))))
+ (home-page "https://wiki.gnome.org/Apps/Yelp")
+ (synopsis "GNOME help browser")
+ (description
+ "Yelp is the help viewer in Gnome. It natively views Mallard, DocBook,
+man, info, and HTML documents. It can locate documents according to the
+freedesktop.org help system specification.")
+ (license license:gpl2+)))