summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-08-30 11:31:05 +0200
committerLudovic Courtès <ludo@gnu.org>2015-08-30 12:14:44 +0200
commit600233bdd2d52d8d8e2d7afc5628e5ac42d52c95 (patch)
tree2788a7e91d765d3e1c0f525f2023c29f9bdc2d37
parent30dc88d975c60c6b7ca886d131d3fed1dacbad9f (diff)
downloadpatches-600233bdd2d52d8d8e2d7afc5628e5ac42d52c95.tar
patches-600233bdd2d52d8d8e2d7afc5628e5ac42d52c95.tar.gz
gnu: clutter: Add "doc" output.
* gnu/packages/gnome.scm (clutter)[outputs]: New field. [arguments]: Pass --with-html-dir.
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3fd2e53e23..790ec763b4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2629,6 +2629,8 @@ without stepping on each others toes.")
(base32
"1b0ikh9q3c3qnny3kbvhqih35449q8ajcbh7zkm8k3kykwfx4scf"))))
(build-system gnu-build-system)
+ (outputs '("out"
+ "doc")) ;9 MiB of gtk-doc HTML pages
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-genmarshal
("gobject-introspection" ,gobject-introspection)
@@ -2649,7 +2651,12 @@ without stepping on each others toes.")
`(("libxkbcommon" ,libxkbcommon)
("udev" ,eudev)))
(arguments
- `(#:configure-flags '("--enable-x11-backend=yes")
+ `(#:configure-flags (list "--enable-x11-backend=yes"
+
+ ;; This produces share/doc/{clutter,cally}.
+ (string-append "--with-html-dir="
+ (assoc-ref %outputs "doc")
+ "/share/doc"))
;; XXX FIXME: Get test suite working. It would probably fail in the
;; same way the cogl tests fail, since clutter is based on cogl.
#:tests? #f))