summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-11-16 18:28:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-11-20 20:23:03 +0100
commit561965941cd4b04ccb1c47bdb53ab121421f0518 (patch)
tree7a15850521ccae6a322e6d91aea467a97633d826
parent9cf5245497b84ff5fd7fb10f9bab1fe17c202e5d (diff)
downloadpatches-561965941cd4b04ccb1c47bdb53ab121421f0518.tar
patches-561965941cd4b04ccb1c47bdb53ab121421f0518.tar.gz
gnu: Add libxml++.
* gnu/packages/gnome.scm (libxml++): New variable.
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0bd4c4e9b6..abab459730 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4224,3 +4224,30 @@ services.")
"This package contains a systray applet for NetworkManager. It displays
the available networks and allows users to easily switch between them.")
(license license:gpl2+)))
+
+(define-public libxml++
+ (package
+ (name "libxml++")
+ (version "2.91.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0h4h7hhh9lg8h34py116517m3wqbzhd5v63k1c6pp1p2a43s18fs"))))
+ (build-system gnu-build-system)
+ ;; libxml++-3.0.pc refers to all these.
+ (propagated-inputs
+ `(("libxml2" ,libxml2)
+ ("glibmm" ,glibmm)))
+ (native-inputs
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)))
+ (home-page "http://libxmlplusplus.sourceforge.net/")
+ (synopsis "C++ wrapper for XML parser library libxml2")
+ (description
+ "This package provides a C++ wrapper for the XML parser library
+libxml2.")
+ (license license:lgpl2.1+)))