summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-26 02:20:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-26 03:07:54 +0200
commitdc36bfec50de76aca1ea0d5714043b6ad9c52747 (patch)
tree9332c0dda9258dcbef6e20c4394cc53bd7ec43d0
parent51a11b82a317d620026ca1bb2b7e6d29a1c1ee75 (diff)
downloadpatches-dc36bfec50de76aca1ea0d5714043b6ad9c52747.tar
patches-dc36bfec50de76aca1ea0d5714043b6ad9c52747.tar.gz
gnu: nethogs: Use explicitly BASE32 source hash.
Works around error: failed to load 'gnu/packages/networking.scm': ice-9/eval.scm:293:34: Wrong type to apply: #<syntax-transformer base32> when manually building from git. * gnu/packages/networking.scm (nethogs)[source]: Use BASE32 explicitly.
-rw-r--r--gnu/packages/networking.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index b0c1440fd3..fd29370841 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1731,8 +1731,9 @@ the bandwidth, loss, and other parameters.")
(url "https://github.com/raboof/nethogs")
(commit (string-append "v" version))))
(hash
- (content-hash "0sn1sdp86akwlm4r1vmkxjjl50c0xaisk91bbz57z7kcsaphxna9"
- sha256))
+ (content-hash
+ (base32 "0sn1sdp86akwlm4r1vmkxjjl50c0xaisk91bbz57z7kcsaphxna9")
+ sha256))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(inputs