summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-25 13:27:37 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 00:56:19 +0200
commitd79c917f2dd7550c6737fede49c77679f0a83770 (patch)
tree16eed0dd65462a379c376c8e13a3fd47be5b276c
parentdd003125f72c0e7d6e1f10b7ccd7969fe674c9c1 (diff)
downloadpatches-d79c917f2dd7550c6737fede49c77679f0a83770.tar
patches-d79c917f2dd7550c6737fede49c77679f0a83770.tar.gz
gnu: Add python-pytest-pycodestyle.
* gnu/packages/python-check.scm (python-pytest-pycodestyle): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/python-check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 22b9ea8df5..1071abdbad 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -337,6 +338,28 @@ testing framework.")
framework.")
(license license:expat)))
+(define-public python-pytest-pycodestyle
+ (package
+ (name "python-pytest-pycodestyle")
+ (version "2.0.0") ;later versions require python-pytest~=5.4
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-pycodestyle" version))
+ (sha256
+ (base32
+ "02i5gl7pm9cwxk15sn29inz3n8flpj1r3p1l110h43f2na5w8h7z"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pycodestyle" ,python-pycodestyle)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/henry0312/pytest-pycodestyle")
+ (synopsis "Pytest plugin to run pycodestyle")
+ (description "This package provides a plugin to run @code{pycodestyle}
+for the @code{pytest} framework.")
+ (license license:expat)))
+
(define-public python-codacy-coverage
(package
(name "python-codacy-coverage")