summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Karpezo <sirmacik@wioo.waw.pl>2020-05-25 18:05:29 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 00:56:19 +0200
commitc1f3382e6f742ca17513e019e860bbc45f38f83c (patch)
treee0124f2502c7fb9ddb07b3da2bc55bec79ca062a
parent9da87078417bb16ad82652a7d2efd72185c28220 (diff)
downloadpatches-c1f3382e6f742ca17513e019e860bbc45f38f83c.tar
patches-c1f3382e6f742ca17513e019e860bbc45f38f83c.tar.gz
gnu: Add dump.
* gnu/packages/backup.scm (dump): New variable. Signed-off-by: Marius Bakke <marius@gnu.org>
-rw-r--r--gnu/packages/backup.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 0fe6676cc2..e79fe4a85e 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1026,6 +1027,42 @@ stored previously can be read back in full at any time. The program
is format-agnostic, so you can feed virtually any files to it.")
(license license:gpl2+)))
+(define-public dump
+ (package
+ (name "dump")
+ (version "0.4b46")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/dump/dump/"
+ version "/dump-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15rg5y15ak0ppqlhcih78layvg7cwp6hc16p3c58xs8svlkxjqc0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ `("--sysconfdir=/etc"
+ "--disable-readline"
+ "--disable-rmt")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("openssl" ,openssl-1.0)
+ ("zlib" ,zlib)
+ ("util-linux" ,util-linux "lib")
+ ("e2fsprogs" ,e2fsprogs)))
+ (home-page "https://dump.sourceforge.io/")
+ (synopsis "Ext2/3/4 filesystem dump/restore utilities")
+ (description "Dump examines files in a filesystem, determines which ones
+need to be backed up, and copies those files to a specified disk, tape or
+other storage medium. Subsequent incremental backups can then be layered on
+top of the full backup. The restore command performs the inverse function of
+dump; it can restore a full backup of a filesystem. Single files and
+directory subtrees may also be restored from full or partial backups in
+interractive mode.")
+ (license license:bsd-3)))
+
(define-public burp
(package
(name "burp")