summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-25 21:41:22 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-26 09:54:33 +0300
commit5f833e0495f00a72f8d34a63e8afbc531afdd22d (patch)
tree0cf76161d7aa26706de3fe2994b73ca9c3016598
parentdc36bfec50de76aca1ea0d5714043b6ad9c52747 (diff)
downloadpatches-5f833e0495f00a72f8d34a63e8afbc531afdd22d.tar
patches-5f833e0495f00a72f8d34a63e8afbc531afdd22d.tar.gz
gnu: go-github-com-blang-semver: Update version string.
The commit was actually the tag for 3.3.0. * gnu/packages/golang.scm (go-github-com-blang-semver)[version]: Retag as 3.3.0. [source]: Update to use version string.
-rw-r--r--gnu/packages/golang.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8dd276562a..31022ebf41 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -978,28 +978,26 @@ optimized for performance yet simple to use.")
(license license:expat))))
(define-public go-github-com-blang-semver
- (let ((commit "60ec3488bfea7cca02b021d106d9911120d25fe9")
- (revision "0"))
- (package
- (name "go-github-com-blang-semver")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/blang/semver.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19pli07y5592g4dyjyj0jq5rn548vc3fz0qg3624vm1j5828p1c2"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/blang/semver"))
- (home-page "https://github.com/blang/semver")
- (synopsis "Semantic versioning library written in Go")
- (description "Semver is a library for Semantic versioning written in Go.")
- (license license:expat))))
+ (package
+ (name "go-github-com-blang-semver")
+ (version "3.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/blang/semver.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19pli07y5592g4dyjyj0jq5rn548vc3fz0qg3624vm1j5828p1c2"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/blang/semver"))
+ (home-page "https://github.com/blang/semver")
+ (synopsis "Semantic versioning library written in Go")
+ (description "Semver is a library for Semantic versioning written in Go.")
+ (license license:expat)))
(define-public go-github-com-emicklei-go-restful
(let ((commit "89ef8af493ab468a45a42bb0d89a06fccdd2fb22")