summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-25 22:14:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-26 09:54:34 +0300
commit4ddd50c60817588b38ea1bf69e106c2bc7fda938 (patch)
tree52cedc94350c9f647fac716a34d2057f2be2a582
parent4672f2c23cbbc75f83e548a5ef4246a3394bd9ca (diff)
downloadpatches-4ddd50c60817588b38ea1bf69e106c2bc7fda938.tar
patches-4ddd50c60817588b38ea1bf69e106c2bc7fda938.tar.gz
gnu: go-github-com-ccding-go-stun: Update version string.
The commit was also tagged 0.1.1. * gnu/packages/syncthing.scm (go-github-com-ccding-go-stun)[version]: Change to tagged version. [source]: Update to use version string.
-rw-r--r--gnu/packages/syncthing.scm42
1 files changed, 20 insertions, 22 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 740981e937..8ca5ab5680 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1035,29 +1035,27 @@ virtual connections from a single physical connection.")
(license expat)))
(define-public go-github-com-ccding-go-stun
- (let ((commit "be486d185f3dfcb2dbf8429332da50a0da7f95a6")
- (revision "2"))
- (package
- (name "go-github-com-ccding-go-stun")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ccding/go-stun.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gr0rw1c1y7wh6913lyn5k4ig023by27i36bly6am8dwgrgp34ww"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/ccding/go-stun"))
- (synopsis "STUN client implementation")
- (description "Go-stun is a go implementation of the STUN client (RFC 3489
+ (package
+ (name "go-github-com-ccding-go-stun")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccding/go-stun.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gr0rw1c1y7wh6913lyn5k4ig023by27i36bly6am8dwgrgp34ww"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/ccding/go-stun"))
+ (synopsis "STUN client implementation")
+ (description "Go-stun is a go implementation of the STUN client (RFC 3489
and RFC 5389).")
- (home-page "https://github.com/ccding/go-stun")
- (license asl2.0))))
+ (home-page "https://github.com/ccding/go-stun")
+ (license asl2.0)))
(define-public go-github-com-cespare-xxhash
(package