summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-25 22:08:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-26 09:54:34 +0300
commit4672f2c23cbbc75f83e548a5ef4246a3394bd9ca (patch)
treed3054e7673c6df781573a3c39090d63b2aec95fa
parent1e07bd2aa7fd3a112a308ae6cf84603f2effe114 (diff)
downloadpatches-4672f2c23cbbc75f83e548a5ef4246a3394bd9ca.tar
patches-4672f2c23cbbc75f83e548a5ef4246a3394bd9ca.tar.gz
gnu: go-github-com-stathat-go: Update version string.
The commit was also tagged 1.0.0. * gnu/packages/syncthing.scm (go-github-com-stathat-go)[version]: Retag 1.0.0. [source]: Update to use version string.
-rw-r--r--gnu/packages/syncthing.scm40
1 files changed, 19 insertions, 21 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index a082e8a05f..740981e937 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -492,27 +492,25 @@ higher-level API for doing so.")
(license isc)))
(define-public go-github-com-stathat-go
- (let ((commit "74669b9f388d9d788c97399a0824adbfee78400e")
- (revision "0"))
- (package
- (name "go-github-com-stathat-go")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/stathat/go")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1zzlsl24dyr202qkr2pay22m6d0gb7ssms77wgdx0r0clgm7dihw"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/stathat/go"))
- (synopsis "Post statistics to StatHat")
- (description "This is a Go package for posting to a StatHat account.")
- (home-page "https://github.com/stathat/go")
- (license expat))))
+ (package
+ (name "go-github-com-stathat-go")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stathat/go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1zzlsl24dyr202qkr2pay22m6d0gb7ssms77wgdx0r0clgm7dihw"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/stathat/go"))
+ (synopsis "Post statistics to StatHat")
+ (description "This is a Go package for posting to a StatHat account.")
+ (home-page "https://github.com/stathat/go")
+ (license expat)))
(define-public go-github-com-rcrowley-go-metrics
(let ((commit "cac0b30c2563378d434b5af411844adff8e32960")