summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-26 09:49:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-26 09:54:36 +0300
commit3d2e2bf6b85b5d54e331b8572050a395be87d134 (patch)
treee91496913b7e8a85c8afa8dc09a616b46416e9f2
parenta63077f0032ad904fc7ae57dd79742fe2913a1d2 (diff)
downloadpatches-3d2e2bf6b85b5d54e331b8572050a395be87d134.tar
patches-3d2e2bf6b85b5d54e331b8572050a395be87d134.tar.gz
gnu: go-github-com-prometheus-procfs: Update to 0.0.11.
* gnu/packages/syncthing.scm (go-github-com-prometheus-procfs): Update to 0.0.11. [propagated-inputs]: Add go-golang-org-x-sys.
-rw-r--r--gnu/packages/syncthing.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 6ae7b7b024..be7496e7ca 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -878,7 +878,7 @@ Prometheus metrics.")
(define-public go-github-com-prometheus-procfs
(package
(name "go-github-com-prometheus-procfs")
- (version "0.0.4")
+ (version "0.0.11")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -887,13 +887,15 @@ Prometheus metrics.")
(file-name (git-file-name name version))
(sha256
(base32
- "1z5jq5rjala0a0di4nwk1rai0z9f73qwqj6mgcbpjbg2qknlb544"))))
+ "1msc8bfywsmrgr2ryqjdqwkxiz1ll08r3qgvaka2507z1wpcpj2c"))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/prometheus/procfs"
;; The tests require Go modules, which are not yet supported in Guix's
;; Go build system.
#:tests? #f))
+ (propagated-inputs
+ `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
(synopsis "Go library for reading @file{/proc}")
(description "The @code{procfs} Go package provides functions to retrieve
system, kernel, and process metrics from the @file{/proc} pseudo file system.")