summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-25 21:18:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-26 09:54:35 +0300
commit369aab196d6df12fe6552ad84fcd2db80be0fcbe (patch)
treed9addcf6b0b7bc04ea88d08c4c18f88ddef1ec66
parentc748f5262fa155e8986692c5cae7a584804d28ee (diff)
downloadpatches-369aab196d6df12fe6552ad84fcd2db80be0fcbe.tar
patches-369aab196d6df12fe6552ad84fcd2db80be0fcbe.tar.gz
gnu: go-github-com-mitchellh-go-homedir: Enable tests.
* gnu/packages/golang.scm (go-github-com-mitchellh-go-homedir) [arguments]: Enable tests. Add custom phase to set HOME environment variable.
-rw-r--r--gnu/packages/golang.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fa62a9ad15..44481ed08f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2356,9 +2356,13 @@ statistics for wrapped connections.")
"0ydzkipf28hwj2bfxqmwlww47khyk6d152xax4bnyh60f4lq3nx1"))))
(build-system go-build-system)
(arguments
- (quote (#:import-path "github.com/mitchellh/go-homedir"
- ;; TODO: Tests fail because it tries to access home.
- #:tests? #f)))
+ `(#:import-path "github.com/mitchellh/go-homedir"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-home-directory
+ (lambda _
+ (setenv "HOME" "/")
+ #t)))))
(home-page "https://github.com/mitchellh/go-homedir")
(synopsis "Go library for detecting and expanding the user's home directory without cgo")
(description "This is a Go library for detecting the user's home