summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-15 12:38:43 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-15 15:03:31 +0100
commitdf9f515ebca9bb3670a3d44c726c56744d85c099 (patch)
tree1b3b8aab6d83f8b0ad125d5482826319874141d1
parentca497b43118fc13adb0d244ea0a183491a0d0265 (diff)
downloadpatches-df9f515ebca9bb3670a3d44c726c56744d85c099.tar
patches-df9f515ebca9bb3670a3d44c726c56744d85c099.tar.gz
gnu: rapidjson: Adjust indentation.
* gnu/packages/web.scm (rapidjson): Reindent. Remove unnecessary splicing in arguments while at it.
-rw-r--r--gnu/packages/web.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3c126bb941..bfc21c07a9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -749,33 +749,33 @@ current version of any major web browser.")
(name "rapidjson")
(version "1.1.0")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Tencent/rapidjson.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1jixgb8w97l9gdh3inihz7avz7i770gy2j2irvvlyrq3wi41f5ab"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove code using the problematic JSON license (see
- ;; <https://www.gnu.org/licenses/license-list.html#JSON>).
- (delete-file-recursively "bin/jsonchecker")
- #t))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Tencent/rapidjson.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1jixgb8w97l9gdh3inihz7avz7i770gy2j2irvvlyrq3wi41f5ab"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove code using the problematic JSON license (see
+ ;; <https://www.gnu.org/licenses/license-list.html#JSON>).
+ (delete-file-recursively "bin/jsonchecker")
+ #t))))
(build-system cmake-build-system)
(arguments
- `(,@(if (string-prefix? "aarch64" (or (%current-target-system)
- (%current-system)))
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-aarch-march-detection
- (lambda _
- (substitute* (find-files "." "^CMakeLists\\.txt$")
- (("native") "armv8-a"))
- #t))))
- '())))
+ (if (string-prefix? "aarch64" (or (%current-target-system)
+ (%current-system)))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-aarch-march-detection
+ (lambda _
+ (substitute* (find-files "." "^CMakeLists\\.txt$")
+ (("native") "armv8-a"))
+ #t))))
+ '()))
(home-page "https://github.com/Tencent/rapidjson")
(synopsis "JSON parser/generator for C++ with both SAX/DOM style API")
(description