summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 15:43:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-14 19:47:27 +0100
commit98580bd93a38b23f0584922f35f611ed7b1d33e8 (patch)
treed36550130f1fbaee624cb878a0bed6b56c5b71e8
parent925926bab11782ab0f36dcb7f5c00cf95138866f (diff)
downloadpatches-98580bd93a38b23f0584922f35f611ed7b1d33e8.tar
patches-98580bd93a38b23f0584922f35f611ed7b1d33e8.tar.gz
gnu: Add perl-conf-libconfig.
* gnu/packages/perl.scm (perl-conf-libconfig): New public variable.
-rw-r--r--gnu/packages/perl.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 978062d262..ef337446dd 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -52,7 +52,8 @@
#:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-compression)
#:use-module (gnu packages perl-web)
- #:use-module (gnu packages pkg-config))
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages textutils))
;;;
;;; Please: Try to add new module packages in alphabetic order.
@@ -1348,6 +1349,35 @@ and objects.")
as defined by two typical specimens of Perl coders.")
(license (package-license perl))))
+(define-public perl-conf-libconfig
+ (package
+ (name "perl-conf-libconfig")
+ (version "0.100")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/C/CN/CNANGEL/"
+ "Conf-Libconfig-" version ".tar.gz"))
+ (sha256
+ (base32 "0qdypqd7mx96bwdjlv13fn6p96bs4w0yv94yv94xa7z5lqkdj4rg"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)
+ ("perl-test-deep" ,perl-test-deep)
+ ("perl-test-exception" ,perl-test-exception)
+ ("perl-test-warn" ,perl-test-warn)))
+ (inputs
+ `(("libconfig" ,libconfig)))
+ (home-page "https://metacpan.org/release/Conf-Libconfig")
+ (synopsis "Perl extension for libconfig")
+ (description
+ "Conf::Libconfig is a Perl interface to the libconfig configuration file
+library. It support scalar, array, and hash data structures just like its C/C++
+counterpart. It reduces the effort required to implement a configuration file
+parser in your Perl programme and allows sharing configuration files between
+languages.")
+ (license bsd-3)))
+
(define-public perl-config-any
(package
(name "perl-config-any")