summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-06 15:38:20 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:12 +0100
commit69866690128615bea022080138d91da4789948db (patch)
treeecbc69aaf842d4170b32fc7c7578455cd4bfba82
parent9820a02858840d6f0aef6d13541aaf7148e50651 (diff)
downloadpatches-69866690128615bea022080138d91da4789948db.tar
patches-69866690128615bea022080138d91da4789948db.tar.gz
gnu: python-hdf5: Correct inputs.
According to setup.py python-six is requried at run-time, thus has to be a propagated input. * gnu/packages/python.scm (python-hdf5) [inputs]: Move `python-six` to [propagated-inputs].
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index defec4963f..13bc5ff43b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -742,10 +742,10 @@ and verifies that it matches the intended target hostname.")
(string-append "['" prefix "/lib" "']")))
#t))))))
(propagated-inputs
- `(("python-numpy" ,python-numpy)))
+ `(("python-six" ,python-six)
+ ("python-numpy" ,python-numpy)))
(inputs
- `(("hdf5" ,hdf5)
- ("python-six" ,python-six)))
+ `(("hdf5" ,hdf5)))
(native-inputs
`(("python-cython" ,python-cython)
("python-pkgconfig" ,python-pkgconfig)))