summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-06 18:14:29 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:17 +0100
commit5e1c9d242abe6c992c4435d7cfb035d2b6583679 (patch)
treeb966f7b847f077ed237863e09807fe1540d31451
parentd2a8db92feb6ee2864ee3c6981dd43055ea91339 (diff)
downloadpatches-5e1c9d242abe6c992c4435d7cfb035d2b6583679.tar
patches-5e1c9d242abe6c992c4435d7cfb035d2b6583679.tar.gz
gnu: python-singledispatch: correct inputs.
python-six is only required for conversion, not at run-time * gnu/packages/python.scm (python-singledispatch, python2-singledispatch): [inputs] Move python-six to [native-inputs].
-rw-r--r--gnu/packages/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 40e6ac9c08..ea6fc83bbf 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5270,8 +5270,8 @@ It is written entirely in Python.")
(base32
"171b7ip0hsq5qm83np40h3phlr36ym18w0lay0a8v08kvy3sy1jv"))))
(build-system python-build-system)
- (inputs
- `(("python-six" ,python-six)))
+ (native-inputs
+ `(("python-six" ,python-six))) ; required for conversion, not at run-time
(home-page
"http://docs.python.org/3/library/functools.html#functools.singledispatch")
(synopsis "Backport of singledispatch feature from Python 3.4")