summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Saavedra <rennes@openmailbox.org>2016-02-20 23:25:12 -0600
committer宋文武 <iyzsong@gmail.com>2016-02-22 19:57:35 +0800
commitb784b1a9ea2a72b600abfeae486edd0bcf3f8598 (patch)
treeefda60ae0f36c5e816b5316961c0853e15b65db8
parent8b15f42c735a77812291b9aa9b9738ef7f298839 (diff)
downloadpatches-b784b1a9ea2a72b600abfeae486edd0bcf3f8598.tar
patches-b784b1a9ea2a72b600abfeae486edd0bcf3f8598.tar.gz
gnu: Add gnome-screenshot.
* gnu/packages/gnome.scm (gnome-screenshot): New variable.
-rw-r--r--gnu/packages/gnome.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4efa01c2b4..d68633e83d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4711,6 +4711,37 @@ can add your own files to the collection.")
license:cc-by-sa2.0
license:cc-by-sa3.0))))
+(define-public gnome-screenshot
+ (package
+ (name "gnome-screenshot")
+ (version "3.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0hc8m435q7yzvrw7jpi53kaxpmrd9w59sm7c5wibh2ng9azlv9pb"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("libcanberra" ,libcanberra)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)))
+ (home-page "https://git.gnome.org/browse/gnome-screenshot")
+ (synopsis "Take pictures of your screen")
+ (description
+ "GNOME Screenshot is a utility used for taking screenshots of the entire
+screen, a window or a user defined area of the screen, with optional
+beautifying border effects.")
+ (license license:gpl2+)))
+
(define-public gnome
(package
(name "gnome")