summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-14 15:49:47 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 19:01:16 -0800
commitb6f0b9fb68bd85e662698ddf8a066075f3cd8e9a (patch)
treeeb236e6894bb0246455120fc6e2432472bb3e55e
parent7d387305077946c3a377f7247a7c32068ff55441 (diff)
downloadpatches-b6f0b9fb68bd85e662698ddf8a066075f3cd8e9a.tar
patches-b6f0b9fb68bd85e662698ddf8a066075f3cd8e9a.tar.gz
gnu: Add python-billiard.
* gnu/packages/python.scm (python-billiard, python2-billiard): New variables.
-rw-r--r--gnu/packages/python.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index aee730b8d9..869ce29689 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7973,3 +7973,38 @@ RabbitMQ messaging server is the most popular implementation.")
(inputs `(("python2-setuptools" ,python2-setuptools)
("python2-unittest2" ,python2-unittest2)
,@(package-inputs kombu))))))
+
+(define-public python-billiard
+ (package
+ (name "python-billiard")
+ (version "3.3.0.22")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "billiard" version))
+ (sha256
+ (base32
+ "0zp7h6a58alrb3mwdw61jds07395j4j0mj6iqsb8czrihw9ih5nj"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "http://github.com/celery/billiard")
+ (synopsis
+ "Python multiprocessing fork with improvements and bugfixes")
+ (description
+ "Billiard is a fork of the Python 2.7 multiprocessing package. The
+multiprocessing package itself is a renamed and updated version of R Oudkerk's
+pyprocessing package. This standalone variant is intended to be compatible with
+Python 2.4 and 2.5, and will draw its fixes/improvements from python-trunk.")
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay python2-billiard))))))
+
+(define-public python2-billiard
+ (let ((billiard (package-with-python2
+ (strip-python2-variant python-billiard))))
+ (package
+ (inherit billiard)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)
+ ("python2-unittest2" ,python2-unittest2)
+ ("python2-mock" ,python2-mock)
+ ,@(package-native-inputs billiard))))))