summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-21 10:56:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-21 16:16:54 +0200
commit62fe2d47529b2c4dd757bb0c211d0515610ea6a5 (patch)
tree38a783afee73ef6e7a38ab511342fe3865c55cf2
parente05035c70d075e2ed0a57a3349e171ac3d305a21 (diff)
downloadpatches-62fe2d47529b2c4dd757bb0c211d0515610ea6a5.tar
patches-62fe2d47529b2c4dd757bb0c211d0515610ea6a5.tar.gz
gnu: xvid: Use 'modify-phases'.
* gnu/packages/video.scm (xvid)[arguments]: Use 'modify-phases'.
-rw-r--r--gnu/packages/video.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ab1cae803f..54fdde0046 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1170,13 +1170,13 @@ format changes.")
(native-inputs `(("yasm" ,yasm)))
(arguments
'(#:phases
- (alist-cons-before
- 'configure 'pre-configure
- (lambda _
- (chdir "build/generic")
- (substitute* "configure"
- (("#! /bin/sh") (string-append "#!" (which "sh")))))
- %standard-phases)
+ (modify-phases %standard-phases
+ (add-before
+ 'configure 'pre-configure
+ (lambda _
+ (chdir "build/generic")
+ (substitute* "configure"
+ (("#! /bin/sh") (string-append "#!" (which "sh")))))))
;; No 'check' target.
#:tests? #f))
(home-page "https://www.xvid.com/")