summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-02-13 21:40:22 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-02-21 18:59:39 -0800
commit1cf536521de0b6cdd096d6f396bd9a5bf117f7d8 (patch)
tree324a95fbace948cecd20288bbae59df1841fca9c
parentbb7518b1e8c579648919fe2b2195a0a3111e471c (diff)
downloadpatches-1cf536521de0b6cdd096d6f396bd9a5bf117f7d8.tar
patches-1cf536521de0b6cdd096d6f396bd9a5bf117f7d8.tar.gz
gnu: Add python-pyquery.
* gnu/packages/python.scm (python-pyquery, python2-pyquery): New variables.
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c7e0e14ce3..aedc163ccc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7775,3 +7775,33 @@ file.")
(define-public python2-pastedeploy
(package-with-python2 python-pastedeploy))
+
+(define-public python-pyquery
+ (package
+ (name "python-pyquery")
+ (version "1.2.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pyquery" version))
+ (sha256
+ (base32
+ "1ikz1387nsp0pp7mzzr6ip9n5gr67acpap24yn33987v7fkjp0sa"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-lxml" ,python-lxml)
+ ("python-cssselect" ,python-cssselect)))
+ (home-page "https://github.com/gawel/pyquery")
+ (synopsis "Make jQuery-like queries on xml documents")
+ (description "pyquery allows you to make jQuery queries on xml documents.
+The API is as much as possible the similar to jQuery. pyquery uses lxml for
+fast xml and html manipulation.")
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay python2-pyquery))))))
+
+(define-public python2-pyquery
+ (let ((pyquery (package-with-python2
+ (strip-python2-variant python-pyquery))))
+ (package
+ (inherit pyquery)
+ (native-inputs `(("python2-setuptools" ,python2-setuptools))))))