summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-05-18 02:17:35 -0400
committerLeo Famulari <leo@famulari.name>2018-05-21 13:34:18 -0400
commit4699ffa383ea50442fbe659f687cb5652ab5a557 (patch)
tree39cbaabb266acc81eece1d13e793f078a3cf499d
parent7d798b3bb3342f9a29d0214a2d6becd3c9482532 (diff)
downloadpatches-4699ffa383ea50442fbe659f687cb5652ab5a557.tar
patches-4699ffa383ea50442fbe659f687cb5652ab5a557.tar.gz
gnu: procps: Update to 3.3.14.
* gnu/packages/linux.scm (procps): Update to 3.3.14. [arguments]: Remove obsolete phase 'disable-strtod-test' because the change has been upstreamed.
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c8ad2ef356..4d3bda8824 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -695,14 +695,14 @@ by Robert Shea and Robert Anton Wilson.")
(define-public procps
(package
(name "procps")
- (version "3.3.12")
+ (version "3.3.14")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/procps-ng/Production/"
"procps-ng-" version ".tar.xz"))
(sha256
(base32
- "1m57w6jmry84njd5sgk5afycbglql0al80grx027kwqqcfw5mmkf"))))
+ "0v3j6rkzzscqds37i105cxx3q4dk04rsgpqfd5p7hzcvk59h5njy"))))
(build-system gnu-build-system)
(arguments
'(#:modules ((guix build utils)
@@ -711,15 +711,6 @@ by Robert Shea and Robert Anton Wilson.")
(srfi srfi-26))
#:phases
(modify-phases %standard-phases
- (add-before 'check 'disable-strtod-test
- (lambda _
- ;; Disable the 'strtod' test, which fails on 32-bit systems.
- ;; This is what upstream does:
- ;; <https://gitlab.com/procps-ng/procps/commit/100afbc1491be388f1429021ff65d969f4b1e08f>.
- (substitute* "Makefile"
- (("^(TESTS|check_PROGRAMS) = .*$" all)
- (string-append "# " all "\n")))
- #t))
(add-after
'install 'post-install
;; Remove commands and man pages redudant with