summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-01-17 20:34:25 -0800
committerChristopher Allan Webber <cwebber@dustycloud.org>2016-01-18 15:10:38 -0800
commit1348185ac2bb48b373495830267cff8ddc6b1fa5 (patch)
tree0148c21ff46f45a4119ef239128360a49fbeaecc
parentaac783cac54e48bb5d85d911bcad198fe3c9de04 (diff)
downloadpatches-1348185ac2bb48b373495830267cff8ddc6b1fa5.tar
patches-1348185ac2bb48b373495830267cff8ddc6b1fa5.tar.gz
gnu: Add linux-libre-4.2.5
* gnu/packages/linux.scm (linux-libre-4.2.5): New variable.
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 779b9c85b8..09014d6076 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -317,6 +318,22 @@ It has been modified to remove all non-free binary blobs.")
(license license:gpl2)
(home-page "http://www.gnu.org/software/linux-libre/"))))
+;; This older version of linux-libre is being added because it was found
+;; that newer versions (or at least 4.3.3) of linux-libre were not reading
+;; the hardware clock on (at least Libreboot-enabled) Thinkpad x200
+;; machines. See <http://bugs.gnu.org/22274>.
+
+(define-public linux-libre-4.2.5
+ (package
+ (inherit linux-libre)
+ (version "4.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (linux-libre-urls version))
+ (sha256
+ (base32
+ "13ar9sghm2g5w2km9x2d07q3lh81rz286d6slklv56qanm24chzx"))))))
+
;;;
;;; Pluggable authentication modules (PAM).