summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-05-25 14:20:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-05-25 14:20:53 +0300
commit0b96705889df3d2fb9a14ec73213d137a256986c (patch)
tree6694141506a2e64d10da72063de5bfc1e68d746f
parent607bfab5ec8f096c651bd44d4fbc8e568279327d (diff)
downloadpatches-0b96705889df3d2fb9a14ec73213d137a256986c.tar
patches-0b96705889df3d2fb9a14ec73213d137a256986c.tar.gz
gnu: tensorflow: Fix build with python-3.8.base-for-series-4090base-for-series-4029
* gnu/packages/machine-learning.scm (tensorflow)[arguments]: Also import python-version from python-build-system. Adjust 'python3.7-compatibility to also add python-3.8 compatibility. Adjust 'install-python to not hardcode the python version.
-rw-r--r--gnu/packages/machine-learning.scm21
1 files changed, 17 insertions, 4 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 6552d171bf..cf00a84e86 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1403,7 +1403,11 @@ Python.")
(list "CC=gcc")
#:modules ((ice-9 ftw)
(guix build utils)
- (guix build cmake-build-system))
+ (guix build cmake-build-system)
+ ((guix build python-build-system)
+ #:select (python-version)))
+ #:imported-modules (,@%cmake-build-system-modules
+ (guix build python-build-system))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-source-file-times-to-1980
@@ -1428,6 +1432,12 @@ Python.")
;; optional package.
(substitute* "tensorflow/tools/pip_package/setup.py"
((".*'tensorboard >.*") ""))
+
+ ;; Fix the build with python-3.8, taken from rejected upstream patch:
+ ;; https://github.com/tensorflow/tensorflow/issues/34197
+ (substitute* (find-files "tensorflow/python" ".*\\.cc$")
+ (("(nullptr,)(\\ +/. tp_print)" _ _ tp_print)
+ (string-append "NULL, " tp_print)))
#t))
(add-after 'python3.7-compatibility 'chdir
(lambda _ (chdir "tensorflow/contrib/cmake") #t))
@@ -1617,16 +1627,19 @@ INSTALL_RPATH " (assoc-ref outputs "out") "/lib)\n")))
(invoke "make" "tf_python_build_pip_package")
#t))
(add-after 'build-pip-package 'install-python
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
- (wheel (car (find-files "../build/tf_python/dist/" "\\.whl$"))))
+ (wheel (car (find-files "../build/tf_python/dist/" "\\.whl$")))
+ (python-version (python-version
+ (assoc-ref inputs "python"))))
(invoke "python" "-m" "pip" "install" wheel
(string-append "--prefix=" out))
;; XXX: broken RUNPATH, see fix-python-build phase.
(delete-file
(string-append
- out "/lib/python3.7/site-packages/tensorflow/contrib/"
+ out "/lib/python" python-version
+ "/site-packages/tensorflow/contrib/"
"seq2seq/python/ops/lib_beam_search_ops.so"))
#t))))))
(native-inputs