summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2020-05-23 18:50:39 -0400
committerLudovic Courtès <ludo@gnu.org>2020-05-25 00:00:27 +0200
commitf81ce752b3395208f911387d95177ecf52d6edbc (patch)
treec4bfed4fe21bb3593e5bcab245bb83f0c7beeaa5
parentb7e1e556b2d0dd6685f41abcf92bb7f0b28f72e9 (diff)
downloadpatches-f81ce752b3395208f911387d95177ecf52d6edbc.tar
patches-f81ce752b3395208f911387d95177ecf52d6edbc.tar.gz
gnu: guile-dsv: Build with Guile 3.0.
* gnu/packages/guile-xyz.scm (guile-dsv)[inputs]: Replace guile-2.2 with guile-3.0. [propagated-inputs]: Replace guile2.2-lib with guile-lib. [arguments]: Add "configure support guile3.0" phase. (guile2.2-dsv): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/guile-xyz.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b1c1fd0f62..8dfce091ef 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -465,8 +465,8 @@ you send to a FIFO file.")
("automake" ,automake)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
- (inputs `(("guile" ,guile-2.2)))
- (propagated-inputs `(("guile2.2-lib" ,guile2.2-lib)))
+ (inputs `(("guile" ,guile-3.0)))
+ (propagated-inputs `(("guile-lib" ,guile-lib)))
(arguments
`(#:modules (((guix build guile-build-system)
#:select (target-guile-effective-version))
@@ -474,6 +474,14 @@ you send to a FIFO file.")
#:imported-modules ((guix build guile-build-system)
,@%gnu-build-system-modules)
#:phases (modify-phases %standard-phases
+ ;; Support Guile 3.0 in configure from upstream commit
+ ;; 4c724577ccf19bb88580f72f2f6b166a0447ce3f
+ (add-before 'bootstrap 'configure-support-guile3.0
+ (lambda _
+ (substitute* "configure.ac"
+ (("GUILE_PKG.*")
+ "GUILE_PKG([3.0 2.0 2.2])"))
+ #t))
(add-before 'configure 'set-guilesitedir
(lambda _
(substitute* "Makefile.in"
@@ -493,7 +501,7 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
- (guile-lib (assoc-ref inputs "guile2.2-lib"))
+ (guile-lib (assoc-ref inputs "guile-lib"))
(version (target-guile-effective-version))
(scm (string-append "/share/guile/site/"
version))
@@ -515,6 +523,13 @@ delimiter-separated values (DSV) data format. Guile-DSV supports the
Unix-style DSV format and RFC 4180 format.")
(license license:gpl3+)))
+(define-public guile2.2-dsv
+ (package
+ (inherit guile-dsv)
+ (name "guile2.2-dsv")
+ (inputs `(("guile" ,guile-2.2)))
+ (propagated-inputs `(("guile-lib" ,guile2.2-lib)))))
+
(define-public guile-fibers
(package
(name "guile-fibers")