summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-04 23:55:12 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-04 23:55:12 +0200
commitcc24623d7189ec03a2b31750daf784b06474cb84 (patch)
treee1d28e0feb09b1fafc4da864c1a6d54213b67b02
parent9d9b576bcd51049f674933ce5406f9ce549b9bf6 (diff)
downloadpatches-cc24623d7189ec03a2b31750daf784b06474cb84.tar
patches-cc24623d7189ec03a2b31750daf784b06474cb84.tar.gz
gnu: bdb: Move documentation to "doc" output.
* gnu/packages/bdb.scm (bdb): Add 'outputs' field. Adjust 'configure' phase to move documentation to the "doc" output.
-rw-r--r--gnu/packages/bdb.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/bdb.scm b/gnu/packages/bdb.scm
index 75a2b72b44..e82a683332 100644
--- a/gnu/packages/bdb.scm
+++ b/gnu/packages/bdb.scm
@@ -34,13 +34,21 @@
(sha256 (base32
"1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
(build-system gnu-build-system)
+ (outputs '("out" ; programs, libraries, headers
+ "doc")) ; 94 MiB of HTML docs
(arguments
'(#:tests? #f ; no check target available
#:phases
(alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ ;; '--docdir' is not honored, so we need to patch.
+ (substitute* "dist/Makefile.in"
+ (("docdir[[:blank:]]*=.*")
+ (string-append "docdir = " doc "/share/doc/bdb")))
+
(zero?
(system* "./dist/configure"
(string-append "--prefix=" out)