summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2020-05-20 22:28:11 -0500
committerLudovic Courtès <ludo@gnu.org>2020-05-25 00:00:28 +0200
commitc873980d187ea6f79a0e91c7d1baf5b301dc5035 (patch)
treed18c744c5ee7b72797837e2f3fe61332251bf874
parentf81ce752b3395208f911387d95177ecf52d6edbc (diff)
downloadpatches-c873980d187ea6f79a0e91c7d1baf5b301dc5035.tar
patches-c873980d187ea6f79a0e91c7d1baf5b301dc5035.tar.gz
gnu: Add protonvpn-cli.
* gnu/packages/vpn.scm (protonvpn-cli): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/vpn.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index da881493bf..8f7fb3b577 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages tls)
#:use-module (gnu packages xml))
@@ -311,6 +313,40 @@ security protocol that utilizes SSL/TLS for key exchange. It is capable of
traversing network address translators (@dfn{NAT}s) and firewalls.")
(license license:gpl2)))
+(define-public protonvpn-cli
+ (package
+ (name "protonvpn-cli")
+ (version "2.2.2")
+ (source
+ (origin
+ ;; PyPI has a ".whl" file but not a proper source release.
+ ;; Thus, fetch code from Git.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ProtonVPN/linux-cli.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ixjb02kj4z79whm1izd8mrn2h0rp9cmw4im1qvp93rahqxdd4n8"))))
+ (build-system python-build-system)
+ (arguments '(#:tests? #f)) ; no tests in repo
+ (native-inputs
+ `(("docopt" ,python-docopt)))
+ (inputs
+ `(("pythondialog" ,python-pythondialog)
+ ("requests" ,python-requests)))
+ (propagated-inputs
+ `(("openvpn" ,openvpn)))
+ (synopsis "Command-line client for ProtonVPN")
+ (description
+ "Official CLI for ProtonVPN, a secure point-to-point virtual private
+networking service with a gratis tier. It can automatically find and connect
+to the fastest servers or use TOR over VPN. The gratis tier offers unlimited
+bandwidth for up to 10 devices.")
+ (home-page "https://github.com/ProtonVPN/linux-cli")
+ (license license:gpl3+)))
+
(define-public tinc
(package
(name "tinc")