summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-05-25 00:32:07 +0200
committerGuix Patches Tester <>2020-05-24 23:36:15 +0100
commit8d259131528986e1e93740c3c520cbe44e09ecd2 (patch)
treeb8eb7dbbed707abcadeb630d1e6fa0c56ed74af7
parent8bd0b533b30d7ee5e03aee99a2eb96d5b0b1c836 (diff)
downloadpatches-8d259131528986e1e93740c3c520cbe44e09ecd2.tar
patches-8d259131528986e1e93740c3c520cbe44e09ecd2.tar.gz
gnu: Add elfutils@0.174.
* gnu/packages/heads.scm (elfutils-0.174): New variable.
-rw-r--r--gnu/packages/heads.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/heads.scm b/gnu/packages/heads.scm
index b28433431c..86ab487b0f 100644
--- a/gnu/packages/heads.scm
+++ b/gnu/packages/heads.scm
@@ -161,3 +161,16 @@ done
(synopsis "Musl-cross gcc 5 toolchain")
(description "Musl-cross toolchain: binutils, gcc 5 and musl.")
(license license:isc))))
+
+(define elfutils-0.174
+ (package
+ (inherit elfutils)
+ (version "0.174")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceware.org/elfutils/ftp/"
+ version "/elfutils-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "12nhr8zrw4sjzrvpf38vl55bq5nm05qkd7nq76as443f0xq7xwnd"))
+ (patches (search-patches "elfutils-tests-ptrace.patch"))))))