summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-10-04 01:15:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-04 01:15:06 +0200
commit86edcc53382c66be06165c62a3934d60ae7aabd8 (patch)
tree890d036d75ae0d38ebff39a4be000959e71409ec
parentc651cbad1e38f18f98984463d7d50254b019576b (diff)
downloadpatches-86edcc53382c66be06165c62a3934d60ae7aabd8.tar
patches-86edcc53382c66be06165c62a3934d60ae7aabd8.tar.gz
Revert "gnu: eudev: Update to 3.2.4 and generate manpages."
This reverts commit c651cbad1e38f18f98984463d7d50254b019576b.
-rw-r--r--gnu/packages/linux.scm50
1 files changed, 15 insertions, 35 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index dd46b5e506..46434b35c8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2055,50 +2055,30 @@ from the module-init-tools project.")
;; The post-systemd fork, maintained by Gentoo.
(package
(name "eudev")
- (version "3.2.4")
+ (version "3.2.2")
(source (origin
(method url-fetch)
- (uri (string-append "https://github.com/gentoo/eudev/archive/v"
- version ".zip"))
- (file-name (string-append name "-" version ".zip"))
+ (uri (string-append
+ "http://dev.gentoo.org/~blueness/eudev/eudev-"
+ version ".tar.gz"))
(sha256
(base32
- "1r1ag0snarygrj5qqxi2xdq9w6g3sfjd5jx1b0fl7zmqlsz3vvxx"))
+ "0qqgbgpm5wdllk0s04pf80nwc8pr93xazwri1bylm1f15zn5ck1y"))
(patches (search-patches "eudev-rules-directory.patch"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "man/make.sh"
- (("/usr/bin/xsltproc")
- (string-append (assoc-ref inputs "xsltproc")
- "/bin/xsltproc")))
- ;; Manual pages are regenerated here.
- (zero? (system* "./autogen.sh"))))
- (add-after 'install 'build-hwdb
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Build OUT/etc/udev/hwdb.bin. This allows 'lsusb' and
- ;; similar tools to display product names.
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* (string-append out "/bin/udevadm")
- "hwdb" "--update"))))))
- #:configure-flags (list "--enable-manpages")))
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'install 'build-hwdb
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Build OUT/etc/udev/hwdb.bin. This allows 'lsusb' and
+ ;; similar tools to display product names.
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* (string-append out "/bin/udevadm")
+ "hwdb" "--update"))))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gperf" ,gperf)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ;; For tests.
+ `(("pkg-config" ,pkg-config)
("perl" ,perl)
- ("python" ,python-wrapper)
- ;; For documentation.
- ("docbook-xml" ,docbook-xml-4.2)
- ("docbook-xsl" ,docbook-xsl)
- ("libxml2" ,libxml2) ;for $XML_CATALOG_FILES
- ("xsltproc", libxslt)))
+ ("gperf" ,gperf)))
(inputs
;; When linked against libblkid, eudev can populate /dev/disk/by-label
;; and similar; it also installs the '60-persistent-storage.rules' file,