summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:14:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:30 +0200
commit20282111e5bd52c68d57d714d90c81463b2c34d0 (patch)
tree1e7ecfdf9a9fd2f7157bc0a7fa4825e84e1170ca
parent36ce05ffddc2962f9ba96f0924a37b37f0ea8724 (diff)
downloadpatches-20282111e5bd52c68d57d714d90c81463b2c34d0.tar
patches-20282111e5bd52c68d57d714d90c81463b2c34d0.tar.gz
gnu: Add texlive-latex-fancyhdr.
* gnu/packages/tex.scm (texlive-latex-fancyhdr): New variable.
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 42b5ef274a..2895f68478 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1821,6 +1821,39 @@ using box macros and flexible verbatim macros. You can box mathematics,
floats, center, flushleft, and flushright, lists, and pages.")
(license license:lppl1.2+)))
+(define-public texlive-latex-fancyhdr
+ (package
+ (name "texlive-latex-fancyhdr")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/fancyhdr"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "04h430agf8aj7ziwyb46xpk95c605rjk1wzhr63m6ylipihidlgw"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/fancyhdr")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/fancyhdr")
+ (synopsis "Extensive control of page headers and footers in LaTeX2e")
+ (description
+ "The package provides extensive facilities, both for constructing headers
+and footers, and for controlling their use (for example, at times when LaTeX
+would automatically change the heading style in use).")
+ (license license:lppl)))
+
(define texlive-texmf
(package
(name "texlive-texmf")