summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:41:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:21 +0200
commitfe7be4deb9425b6a94b716055bba34697f0b9fe9 (patch)
treec14a24cb69915ad0866a54f4ef9f7fed29fdba90
parent7a8cdab4ff2cbb57ee2aef10b022c1f0c4a451fc (diff)
downloadpatches-fe7be4deb9425b6a94b716055bba34697f0b9fe9.tar
patches-fe7be4deb9425b6a94b716055bba34697f0b9fe9.tar.gz
gnu: emacs-git-auto-commit-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-git-auto-commit-mode)[source]: Use GIT-FETCH and GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 06d4056f98..5745b50aa5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11356,14 +11356,13 @@ scroll up to read the function name and then scroll down to original position.")
(version "4.4.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/ryuslash/git-auto-commit-mode/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryuslash/git-auto-commit-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "04avxmalsl3b7zi2vipfw9rb4wrwysnipsbch96skviql9axk870"))))
+ (base32 "0psmr7749nzxln4b500sl3vrf24x3qijp12ir0i5z4x25k72hrlh"))))
(build-system emacs-build-system)
(home-page "https://github.com/ryuslash/git-auto-commit-mode")
(synopsis "Emacs Minor mode to automatically commit and push")