summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-27 22:58:58 -0400
committerLeo Famulari <leo@famulari.name>2017-07-13 00:42:28 -0400
commitdf08f385705dad9f342e7d1f51407d6207d8b557 (patch)
tree19db4a9e9978f07fbe50d399b58ba8b765954f03
parent1d919d32d7cc29657a4d69789b82f73da0483a68 (diff)
downloadpatches-df08f385705dad9f342e7d1f51407d6207d8b557.tar
patches-df08f385705dad9f342e7d1f51407d6207d8b557.tar.gz
gnu: libressl: Provide a TLS-enabled implementation of netcat.
* gnu/packages/tls.scm (libressl)[arguments]: Pass '--enable-nc' to #:configure-flags.
-rw-r--r--gnu/packages/tls.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index b211c9d96a..00e99439b0 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -470,7 +470,9 @@ required structures.")
;; Do as if 'getentropy' was missing since older Linux kernels lack it
;; and libc would return ENOSYS, which is not properly handled.
;; See <https://lists.gnu.org/archive/html/guix-devel/2017-04/msg00235.html>.
- '(#:configure-flags '("ac_cv_func_getentropy=no")))
+ '(#:configure-flags '("ac_cv_func_getentropy=no"
+ ;; Provide a TLS-enabled netcat.
+ "--enable-nc")))
(native-search-paths
;; FIXME: These two variables must designate a single file or directory
;; and are not actually "search paths." In practice it works OK in
@@ -484,9 +486,10 @@ required structures.")
(files '("etc/ssl/certs/ca-certificates.crt")))))
(home-page "https://www.libressl.org/")
(synopsis "SSL/TLS implementation")
- (description "LibreSSL is a version of the TLS/crypto stack forked
-from OpenSSL in 2014, with the goals of modernizing the codebase, improving
-security, and applying best practice development processes.")
+ (description "LibreSSL is a version of the TLS/crypto stack, forked from
+OpenSSL in 2014 with the goals of modernizing the codebase, improving security,
+and applying best practice development processes. This package also includes a
+netcat implementation that supports TLS.")
;; Files taken from OpenSSL keep their license, others are under various
;; non-copyleft licenses.
(license (list license:openssl