summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-03-24 23:07:18 -0400
committerArun Isaac <arunisaac@systemreboot.net>2018-04-20 14:49:26 +0530
commit9835a71d80c57d26e041abbc6d8ca65e4e1277c6 (patch)
treeb7adad26be456eb0d94e2e4caadc6f84aca700a5
parent62950ec7e9ad2e5e172cd73a5722348bf60fcc4f (diff)
downloadpatches-9835a71d80c57d26e041abbc6d8ca65e4e1277c6.tar
patches-9835a71d80c57d26e041abbc6d8ca65e4e1277c6.tar.gz
gnu: emacs-esxml: Fix byte compilation.
* gnu/packages/emacs.scm (emacs-esxml)[arguments]: Add fix-sources phase. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8379d69db2..b8aa9002cf 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -7340,6 +7340,28 @@ Lisp.")
(base32
"00vv8a75wdklygdyr4km9mc2ismxak69c45jmcny41xl44rp9x8m"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-sources
+ (lambda _
+ ;; See: https://github.com/tali713/esxml/pull/28.
+ (substitute* "css-lite.el"
+ ((";;; main interface")
+ (string-append ";;; main interface\n"
+ "(require 'cl-lib)"))
+ (("mapcan")
+ "cl-mapcan")
+ (("',\\(cl-mapcan #'process-css-rule rules\\)")
+ "(cl-mapcan #'process-css-rule ',rules)"))
+ (substitute* "esxml-form.el"
+ ((",esxml-form-field-defn")
+ "#'esxml-form-field-defn"))
+ ;; See: https://github.com/tali713/esxml/issues/25
+ (delete-file "esxpath.el")
+ #t)))))
+ (propagated-inputs
+ `(("emacs-kv" ,emacs-kv)))
(home-page "https://github.com/tali713/esxml/")
(synopsis "SXML for EmacsLisp")
(description "This is XML/XHTML done with S-Expressions in EmacsLisp.