summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-07-05 22:31:03 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-07-15 10:14:31 +0200
commit87ffa416af029722a73b3244b409f86e39086bc3 (patch)
treec8c998a1b180ce442d56aa8e962f351b479821b4
parentda83f0953a040c2f58da7647dc5d773b430e7098 (diff)
downloadpatches-87ffa416af029722a73b3244b409f86e39086bc3.tar
patches-87ffa416af029722a73b3244b409f86e39086bc3.tar.gz
gnu: Add ncurses-with-gpm.
* gnu/packages/linux.scm (ncurses/gpm): New variable.
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1a9e9d709b..58f6f36625 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3013,6 +3013,18 @@ applications running on the Linux console. It allows users to select items
and copy/paste text in the console and in xterm.")
(license license:gpl2+)))
+(define-public ncurses/gpm
+ (package/inherit ncurses
+ (name "ncurses-with-gpm")
+ (arguments
+ (substitute-keyword-arguments (package-arguments ncurses)
+ ((#:configure-flags cf)
+ `(cons (string-append "--with-gpm="
+ (assoc-ref %build-inputs "gpm")
+ "/lib/libgpm.so.2") ,cf))))
+ (inputs
+ `(("gpm" ,gpm)))))
+
(define-public btrfs-progs
(package
(name "btrfs-progs")