summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-08-02 13:10:57 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-08-02 13:11:13 +0200
commit6ba457cc1c0d5b2ea20fa19d0892f7d10de321d6 (patch)
treeaae69df91a23f327c0e14030babfdaecd55be760
parent1db6f137d93b59409fedb3deb24c876649e1b8f2 (diff)
downloadpatches-6ba457cc1c0d5b2ea20fa19d0892f7d10de321d6.tar
patches-6ba457cc1c0d5b2ea20fa19d0892f7d10de321d6.tar.gz
gnu: Add sbcl-cl-str.
* gnu/packages/lisp.scm (sbcl-cl-str): New variable.
-rw-r--r--gnu/packages/lisp.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index e7d0d5a44f..ae76ef9d83 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -6598,3 +6598,38 @@ various string metrics in Common Lisp:
@item Overlap coefficient
@end itemize\n")
(license license:x11)))
+
+(define-public sbcl-cl-str
+ (let ((commit "3d5ec86e3a0199e5973aacde951086dfd754b5e5"))
+ (package
+ (name "sbcl-cl-str")
+ (version (git-version "0.8" "1" commit))
+ (home-page "https://github.com/vindarel/cl-str")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (sha256
+ (base32 "0szzzbygw9h985yxz909vvqrp69pmpcpahn7hn350lnyjislk9ga"))
+ (file-name (git-file-name name version))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("cl-ppcre-unicode" ,sbcl-cl-ppcre-unicode)))
+ (native-inputs
+ `(("prove" ,sbcl-prove)
+ ("prove-asdf" ,sbcl-prove-asdf)))
+ (arguments
+ `(#:asd-file "str.asd"
+ #:asd-system-name "str"
+ #:test-asd-file "str.test.asd"))
+ (synopsis "Modern, consistent and terse Common Lisp string manipulation library")
+ (description "A modern and consistent Common Lisp string manipulation
+library that focuses on modernity, simplicity and discoverability:
+@code{(str:trim s)} instead of @code{(string-trim '(#\\Space ...) s)}), or
+@code{str:concat strings} instead of an unusual format construct; one
+discoverable library instead of many; consistency and composability, where
+@code{s} is always the last argument, which makes it easier to feed pipes and
+arrows.")
+ (license license:expat))))