summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-06 20:12:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:44:25 +0100
commit294ff39d27c4a3ff0dbc2e2f8b8af40c21bf3aaa (patch)
tree021d5b175053bcb54f7329f71dafdc78bff42479
parent9f475e3c3faa7c522a9146ffa870872ecd775bcb (diff)
downloadpatches-294ff39d27c4a3ff0dbc2e2f8b8af40c21bf3aaa.tar
patches-294ff39d27c4a3ff0dbc2e2f8b8af40c21bf3aaa.tar.gz
gnu: dconf-editor: Update to 3.28.0.
* gnu/packages/gnome.scm (dconf-editor): Update to 3.28.0. [build-system]: Use meson-build-system. [native-inputs]: Add gtk+:bin and vala.
-rw-r--r--gnu/packages/gnome.scm19
1 files changed, 6 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a915239aa5..2629b286f8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6166,7 +6166,7 @@ beautifying border effects.")
(define-public dconf-editor
(package
(name "dconf-editor")
- (version "3.26.2")
+ (version "3.28.0")
(source
(origin
(method url-fetch)
@@ -6175,21 +6175,14 @@ beautifying border effects.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1lcarg8igsqpq4iv5834mf9kz4cmfhfw11bwy3x7v7f497z57d18"))))
- (build-system glib-or-gtk-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'skip-gtk-update-icon-cache
- (lambda _
- ;; Don't create 'icon-theme.cache'.
- (substitute* "editor/Makefile"
- (("gtk-update-icon-cache") "true"))
- #t)))))
+ "0nhcpwqrkmpxbhaf0cafvy6dlp6s7vhm5vknl4lgs3l24zc56ns5"))))
+ (build-system meson-build-system)
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
+ ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
(inputs
`(("dconf" ,dconf)
("gtk+" ,gtk+)