summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-13 18:51:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-04 13:49:55 +0200
commit275cce3d87fadbf519bd2c8e9badd8bcbf9aa370 (patch)
tree3e5a6b8e014b5c229e942fde3876c34a9597ac6b
parent18090a9735ab8301383ffa369949d6ace786308e (diff)
downloadpatches-275cce3d87fadbf519bd2c8e9badd8bcbf9aa370.tar
patches-275cce3d87fadbf519bd2c8e9badd8bcbf9aa370.tar.gz
gnu: python-cython: Speed up test suite.
* gnu/packages/python-xyz.scm (python-cython)[arguments]: In the CHECK phase, disable compiler optimizations and enable (some) parallel tests. (cherry picked from commit e9194eb04896165f15830862c42673e96bc5c5f7)
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6410a13df7..2538505472 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3230,7 +3230,12 @@ provides additional functionality on the produced Mallard documents.")
(replace 'check
(lambda _
- (invoke "python" "runtests.py" "-vv"))))))
+ ;; Disable compiler optimizations to greatly reduce the running
+ ;; time of the test suite.
+ (setenv "CFLAGS" "-O0")
+
+ (invoke "python" "runtests.py" "-vv"
+ "-j" (number->string (parallel-job-count))))))))
(home-page "https://cython.org/")
(synopsis "C extensions for Python")
(description "Cython is an optimising static compiler for both the Python