summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-15 12:45:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-15 13:05:22 +0100
commit1574932debdabcabbcd1cbc64b309c649c1a94f2 (patch)
tree4030b735f1f48f0e87a88e475209dcca78418f00
parent769bb5e56bfaa20dc459fbf17e4f2bba3a93dff0 (diff)
downloadpatches-1574932debdabcabbcd1cbc64b309c649c1a94f2.tar
patches-1574932debdabcabbcd1cbc64b309c649c1a94f2.tar.gz
gnu: texlive-bin: Do not truncate output lines.
* gnu/packages/tex.scm (texlive-bin)[arguments]: Change default line limits in build phase.
-rw-r--r--gnu/packages/tex.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index df5a3d8e3a..b7cec6cb9e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -211,6 +211,11 @@
(unpack (assoc-ref %standard-phases 'unpack))
(patch-source-shebangs
(assoc-ref %standard-phases 'patch-source-shebangs)))
+ (substitute* (string-append share "/texmf-dist/web2c/texmf.cnf")
+ ;; Don't truncate lines.
+ (("^error_line = .*$") "error_line = 254\n")
+ (("^half_error_line = .*$") "half_error_line = 238\n")
+ (("^max_print_line = .*$") "max_print_line = 1000\n"))
;; Create symbolic links for the latex variants and their
;; man pages.
(with-directory-excursion (string-append out "/bin/")